<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="distribution" content="global" />
	<meta name="robots" content="follow, all" />
	<meta name="language" content="en, sv" />
	<meta name="viewport" content="width=device-width" />
		<link rel="Shortcut Icon" href="/wp-content/themes/snoflex/images/favicon.png" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="The Mesa Press RSS 2.0" href="https://www.mesapress.com/feed/" />
	<link rel="alternate" type="text/xml" title="The Mesa Press RSS .92" href="https://www.mesapress.com/feed/rss/" />
	<link rel="alternate" type="application/atom+xml" title="The Mesa Press Atom 0.3" href="https://www.mesapress.com/feed/atom/" />
	<title>Russian invasion of Ukraine hits close to home for the Mesa community &#8211; The Mesa Press</title>
<meta name='robots' content='max-image-preview:large' />
<link rel="alternate" type="application/rss+xml" title="The Mesa Press &raquo; Russian invasion of Ukraine hits close to home for the Mesa community Comments Feed" href="https://www.mesapress.com/uncategorized/2022/03/28/russian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mesapress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='dashicons-css'  href='https://www.mesapress.com/wp-includes/css/dashicons.min.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.mesapress.com/wp-includes/js/thickbox/thickbox.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='sbi_styles-css'  href='https://www.mesapress.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=6.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.mesapress.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.mesapress.com/wp-content/plugins/menu-icons/css/fontawesome/css/all.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.mesapress.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.mesapress.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.11' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.mesapress.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.mesapress.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='sno-infographics-widget-style-css'  href='https://www.mesapress.com/wp-content/plugins/sno-infographics/assets/style/sno-infographics-widget-style.css?ver=0.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='sno-pdf-flipbook-plugin-style-css'  href='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/style/docs.css?ver=1.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='sno-pdf-flipbook-jquery-ui-style-css'  href='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/style/jquery.ui.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sno-polls-widget-style-css'  href='https://www.mesapress.com/wp-content/plugins/sno-polls/assets/style/sno-polls-widget-style.css?ver=0.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.mesapress.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='sno-comments-css-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/comments/comments.css?ver=20211015' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7CLato%3A400%2C700%7CAdamina%3A400%2C700&#038;display=swap&#038;ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20210512' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.mesapress.com/wp-content/themes/snoflex/style.css?ver=20220303' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/all.css' type='text/css' media='all' integrity="sha384-vSIIfh2YWi9wW0r9iZe7RJPrKwp6bG+s9QZMoITbCckVJqGCCRhc+ccxNcdpHuYu" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css' type='text/css' media='all' integrity="sha384-1CjXmylX8++C7CVZORGA9EwcbYDfZV2D4Kl1pTm3hp2I/usHDafIrgBJNuRTDQ4f" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.mesapress.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.8' type='text/css' media='screen' />
<script type='text/javascript' src='https://www.mesapress.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='sno-comments-js-js-extra'>
/* <![CDATA[ */
var comment_ajax_object = {"ajaxurl":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php","nonce":"0ada823848","jason":"wallestad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/comments/comments.js?ver=20211013' id='sno-comments-js-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.9.2' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.9.2' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20210512' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20210513' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20210513' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.9.2' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.9.2' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.9.2' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.9.2' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20210513' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20220102' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.9.2' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://www.mesapress.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.mesapress.com/wp-json/wp/v2/posts/17070" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mesapress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mesapress.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.2" />
<link rel="canonical" href="https://www.mesapress.com/uncategorized/2022/03/28/russian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community/" />
<link rel='shortlink' href='https://www.mesapress.com/?p=17070' />
<link rel="alternate" type="application/json+oembed" href="https://www.mesapress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mesapress.com%2Funcategorized%2F2022%2F03%2F28%2Frussian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mesapress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mesapress.com%2Funcategorized%2F2022%2F03%2F28%2Frussian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community%2F&#038;format=xml" />


<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="Russian invasion of Ukraine hits close to home for the Mesa community" />
<meta property="og:type" content="article" />
<meta name="author" content="Jennifer Aguilar" />
<meta property="og:url" content="https://www.mesapress.com/uncategorized/2022/03/28/russian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community/" />
<meta property="og:image" content="https://www.mesapress.com/wp-content/uploads/2022/03/WORLD-NEWS-UKRAINE-GET-900x600.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="600" />
	<meta property="og:site_name" content="The Mesa Press" />
	<meta property="og:description" content="*SUPPORT LINKS AVAILABLE AT THE BOTTOM OF THE PAGE     Russia’s invasion of Ukraine has affected many in the San Diego Mesa College community.      On the morning of Feb. 24, Mesa College student Andy Larkin awoke to the sounds of explosions in his hometown of Kyiv. These would document the first attacks by the Russian military..." />
	<meta name="description" content="*SUPPORT LINKS AVAILABLE AT THE BOTTOM OF THE PAGE     Russia’s invasion of Ukraine has affected many in the San Diego Mesa College community.      On the morning of Feb. 24, Mesa College student Andy Larkin awoke to the sounds of explosions in his hometown of Kyiv. These would document the first attacks by the Russian military..." />
	<meta property="article:section" content="News" />
	<meta property="article:tag" content="#mesacollege,Mesa community,Mesa Press,San Diego Mesa College,Ukraine" />
<!-- End of Open Graph Meta Tags -->

<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>
<style type="text/css" media="screen">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</style></head>

<body class="sno-animate-active"><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon"><i class="fas fa-times"></i><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://www.mesapress.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation" class="menu"><li id="menu-item-201" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-201"><a href="https://www.mesapress.com/category/news/">News</a></li>
<li id="menu-item-202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="https://www.mesapress.com/category/opinion/">Opinion</a></li>
<li id="menu-item-15052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15052"><a href="https://www.mesapress.com/category/a-e/">Features</a></li>
<li id="menu-item-203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="https://www.mesapress.com/category/sports/">Sports</a></li>
<li id="menu-item-11291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11291"><a href="https://www.mesapress.com/category/podcasts/">Podcasts</a></li>
<li id="menu-item-16342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16342"><a href="https://www.mesapress.com/advertise-with-the-mesa-press/">Advertise with The Mesa Press</a></li>
<li id="menu-item-16343" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16343"><a href="https://www.mesapress.com/?page_id=9968">Classifieds</a></li>
<li id="menu-item-16344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16344"><a href="https://www.mesapress.com/about/">About The Mesa Press</a></li>
<li id="menu-item-16345" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16345"><a href="https://www.mesapress.com/staff/">Staff</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><h1 aria-hidden="true"><div class="header-text"><a href="http://www.mesapress.com#mobile">The Mesa Press</a></div></h1><div id="hover-menu-side"><div class="sno-menu-side menu-icon"><i class="fas fa-bars"></i><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="leaderboardwrap">
	<div class="leaderboard">
		<div class="leaderboardad snoads_leaderboard" data-ad_spot_id="924" data-ad_fill="" data-sno_ads_id="273"></div>
	</div>
</div><div class="headerwrap"><div id="header" style="position:relative;"><h1><a href="http://www.mesapress.com">The Mesa Press</a></h1><p>The independent student news site of San Diego Mesa College.</p></div></div><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft classic-icon">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style>    	<a target="_blank" href="https://www.mesapress.com/feed/rss/">
        	<div class="sno-icon social-border sno-rss">
	        	<i class="fa fa-rss"></i>
	        	<span class="icon-hidden-text">RSS Feed</span>
	        </div>
		</a>
        
        								   	    										
    
        				
   	    
    
    
    		<a target="_blank" href="https://www.snapchat.com/add/mesa.press">
    		<div class="sno-icon social-border sno-snapchat">
        		<i class="fa fa-snapchat-ghost"></i>
        		<span class="icon-hidden-text">Snapchat</span>
        	</div>
    	</a>
        				
        				    					
    		<a target="_blank" href="https://soundcloud.com/mesa-press-audio-archive">
    		<div class="sno-icon social-border sno-soundcloud">
        		<i class="fa fa-soundcloud"></i>
        		<span class="icon-hidden-text">SoundCloud</span>
        	</div>
    	</a>
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/mesa.press">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="http://www.twitter.com/themesapress">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/themesapress">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   			</div>

			<div class="topnavbarcenter">
		        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform9025" action="https://www.mesapress.com/">
			<div class="search-button-container" id="searchthis9025">
			<button type="submit" disabled="disabled" id="sno-search-navbar-9025" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s9025" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s9025" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit9025" style="display:none;" value="Search" />
		</form>
				</div>
			
	</div>
	<div class="clear"></div>
</div><div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='left' 
						data-margin='4' 
						data-style='Blocks' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='970'><div class="subnavbarcontainer"><div id="subnavbar" class="sno-classic-menuwrap"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-main-navigation-container"><ul id="menu-main-navigation-1" class="sf-menu sno-bottom-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-201"><a href="https://www.mesapress.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="https://www.mesapress.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15052"><a href="https://www.mesapress.com/category/a-e/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="https://www.mesapress.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11291"><a href="https://www.mesapress.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16342"><a href="https://www.mesapress.com/advertise-with-the-mesa-press/">Advertise with The Mesa Press</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16343"><a href="https://www.mesapress.com/?page_id=9968">Classifieds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16344"><a href="https://www.mesapress.com/about/">About The Mesa Press</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16345"><a href="https://www.mesapress.com/staff/">Staff</a></li>
</ul></div><ul class='sno-menu-more sf-arrows' style='display:none'><li class='menu-more-item-top'><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a><ul class="sno-hac-menu-more"</ul></li></ul></nav></div></div><div class="clear"></div></div></div></div></div><div class="clear"></div>				<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:3000,
        					speed:1300    					});
					});
				</script><div class="breakingnewswrap"><div id="breakingnews"><div id="newsticker3-demo"><div class="newsticker3-jcarousellite"><ul><li><div class="info"><span class='breakingnewsheadline'><a href='https://www.sdmesa.edu/covid19/documents/Vaccine%20Booster%20Clinic%20March%2017_boost%20and%20win_vers%202.pdf'>Mesa to host Covid-19 vaccine booster clinic March 17</a></span></div><div class="clear"></div></li><li><div class="info"><span class='breakingnewsheadline'>First 3 weeks of Spring '22 semester to be virtual</span></div><div class="clear"></div></li></ul></div></div></div></div><div class="clear"></div><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap "><div class="innerbackground"><div id='snopostid-17070' class='snopostid'><div id='classic_story' class='sno-story-17070'><div id="content"><div id='contentleft'><div class="postarea"><div role="main"><h1 class="storyheadline">Russian invasion of Ukraine hits close to home for the Mesa community</h1><div class="clear"></div><div class="permalinkphotobox"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='17070' data-photo-id='17071' href='#photo'><img src='https://www.mesapress.com/wp-content/uploads/2022/03/WORLD-NEWS-UKRAINE-GET-900x600.jpg' alt='The+people+and+culture+of+Ukraine+are+resilient+and+will+not+be+shaken.+' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge' data-story-id='17070' data-photo-id='17071'><i class='fas fa-search-plus'></i></div></div><div class="clear"></div><div class="captionboxmit"><p class="photocredit"><a href="https://www.mesapress.com/staff_name/aris-messinis-afp-via-getty-images-tns/" class="creditline">Aris Messinis/AFP via Getty Images/TNS</a></p><p class="photocaption">The people and culture of Ukraine are resilient and will not be shaken. </p></div></div><div class="storydetails"><p><span class="storybyline"> <a href="https://www.mesapress.com/staff_name/jennifer-aguilar/" class="creditline">Jennifer Aguilar</a> and <a href="https://www.mesapress.com/staff_name/teal-davis/" class="creditline">Teal Davis</a></span><br /><span class="storydate"><span class="time-wrapper">March 28, 2022</span></span></p></div><span class="storycontent"><p><span style="font-weight: 400;">*SUPPORT LINKS AVAILABLE AT THE BOTTOM OF THE PAGE</span></p>
<p><span style="font-weight: 400;">    Russia’s invasion of Ukraine has affected many in the San Diego Mesa College community. </span></p>
<p><span style="font-weight: 400;">    On the morning of Feb. 24, Mesa College student Andy Larkin awoke to the sounds of explosions in his hometown of Kyiv. These would document the first attacks by the Russian military on the independent nation of Ukraine. For many Mesa students, Ukraine is home to family and friends who are directly influenced by the recent violence. </span></p>
<p><span style="font-weight: 400;">   As Mesa students and staff boldly share their stories and those of close family and friends, one sentiment is clear: despite the violence, the people and culture of Ukraine are resilient and will not be shaken. Despite the physical distance, it is vital that individuals in the U.S. support those in Ukraine and provide aid in any way possible. </span></p>
<p><span style="font-weight: 400;">  Andy Larkin, whose name has been changed for anonymity, described waking up the morning of the first attacks as “one of those fever dreams you would wake up to and think you were still dreaming.” Larkin’s story is one that many Ukrainians can relate to, waking up to the attacks that continue in Ukraine today. </span></p>
<p><span style="font-weight: 400;">  Ivana Polic, who is from Croatia and a mentor in the Mesa PATH fellowship program, expressed concern for several individuals who she knows personally. “The first thing that went through my mind was disbelief and fear for the people in Ukraine,” she said.  She also spoke about how several of her friends who were living in Ukraine at the beginning of the invasion were able to leave their homes and escape the violence, however, there are still other friends and acquaintances who are sheltered in various locations in the country. Dr. Inna Kanevsky</span><span style="font-weight: 400;">, psychology professor at San Diego Mesa College, explained how it was growing up in Ukraine. She expressed her deep connection to Ukraine and its culture, viewing it as home. </span></p>
<p><span style="font-weight: 400;">   As these individuals spoke about the country which lies so dear to themselves, their families, and friends, an overwhelming description of the determination and spirit of those in Ukraine became evident. Ukrainian culture is so distinct and bold that the spirit of Ukraine has become far more evident through this time. “Even if it happens that the Russians advance and finally occupy Ukraine, I think that it is going to come at a huge cost for both the Russian society and the military because Ukraine is going to keep existing, whether or not it is physically there in the borders,” Polic said.</span></p>
<p><span style="font-weight: 400;">   Several people in the Mesa community, who have been directly affected by the conflict, explained that support from the U.S. is incredibly important, not only through sending aid directly to Ukraine, but also in supporting friends and family members who are in your own communities. Over the past weeks, numerous different organizations have offered immediate assistance to the resistance in Ukraine from artillery support to refugee relocation. For those in a position to aid financially, several organizations are doing incredible work in Ukraine and the surrounding countries right now.  However, even for those who may not be in a position to assist financially, many other forms of aid and advocacy exist. House of Ukraine, located in Balboa Park, is currently accepting donations for clothing, sanitary products, and supplies for infants. On a larger level, government sanctions are expected to be a notable influence in this war. </span></p>
<p><span style="font-weight: 400;">    Since the beginning of the invasion, Russia has become the most sanctioned country, even surpassing Iran and North Korea, according to Bloomberg. Many believe that by speaking out about the issue, posting about it on social media platforms, and letting government leaders know that this is an issue important to Americans, our government and leaders will be more likely to take action to offer aid to Ukraine.  </span></p>
<p><span style="font-weight: 400;">    When it comes to Mesa and its support, many Ukrainian staff and students do not believe the college has taken enough action to support and aid those affected. “As a college, there has been nothing that I have heard of that Mesa has been offering, there hasn’t been any acknowledgment…there has not been specific support,” said Dr. Kanevsky. While the college did host a listening circle, “Mesa Cares” by Student Health Services, it was a singular event that occurred on March 7. </span><span style="font-weight: 400;">Chancellor Carlos Cortez, who oversees all three of the colleges in the San Diego District, released a statement addressed to his “colleagues” in which he offered support and directed them to health services for each of the individual colleges, but there has been no other </span><span style="font-weight: 400;">public statements or action taken by Mesa College. </span></p>
<p><span style="font-weight: 400;">   “For now, it is not your problem, but in the future, if this is not stopped right now, it will become your problem,”  Larkin said. He explained that while the conflict may seem distant to many Americans, the outcome of this war will be incredibly impactful not only politically, but economically to global politics and trade. With such intertwined global trade, the U.S. and many other countries have already begun feeling the impacts of the sanctions on Russia and most likely will continue to recognize the impact of the conflict. However, many believe that the consequences of these sanctions are not only necessary but will benefit the country from further sacrifices if the Russian government continues to gain power. </span></p>
<p><span style="font-weight: 400;">   As more and more countries look to aid Ukraine, this conflict has begun to form a united front against the Russian government. Polic shared her pride in her own home country of Croatia and their efforts in providing aid. Having grown up in Croatia in the 1990s, Polic witnessed Croatia’s own independence and compared it to the current conflict. “As much destruction as we can see, I think what keeps me hopeful is all these people that are stepping in and offering their homes, their food, their shelter, their hearts, because we as a nation (Croatia) have this collective experience- that war is something that can happen very quickly and people know how to be united in those conditions,” she said.</span></p>
<p><span style="font-weight: 400;">   While members of the Mesa community are concerned for loved ones still in Ukraine or actively fleeing violence, one continual concern surrounds the role that media and other forms of communication play within the war. Some people are hesitant to contact loved ones or ask them for too many details surrounding their location, as conversations surrounding wiretapping have become more and more popular. </span></p>
<p><span style="font-weight: 400;">   Russian propaganda and misinformation in Russian media has also been at the forefront of conversations surrounding the role and safety of Russian citizens. For many, the reason for the war is still unclear and Russian media is heavily controlled by the government. “It turns out that my aunt believes that it’s the Ukrainians that are doing the bombing…there are people that believe that,” said Dr. Kanevsky. </span></p>
<p><span style="font-weight: 400;">   In recent weeks, Russians have lost access to several different social media platforms where they could access media updates and resources from outside of the country. Larkin talked about how, near the beginning of the conflict, a popular messaging platform was flooded with misinformation and dramatic headlines and that there was “a lot of polar news.” Polic also shared a story of one of her friends who lives in Moscow. “She has been to anti-war protests in Moscow. She saw people being detained and she just feels very disheartened and is thinking about leaving the country, which is also becoming increasingly difficult.”  </span></p>
<p><span style="font-weight: 400;">   The policing of free speech and the consequences of speaking out against the war or the Russian government make clear the lack of power Russians have in their own country. With more recent rhetoric from Putin drawing even more concern for individuals who are in Russia that speak out against the government or the war efforts. With analogies from Putin himself who talked about chewing up “scum and traitors” and spitting them out like gnats, along with an increased effort to attack “false information.” In his recent speech, Putin also said that he believed “self-purification” would make the country a stronger and more unified place. Dr. Kanevskey explained that “he doesn&#8217;t see himself as an inheritor of the Soviet State, that was supposedly built in communism, but more like the Russian Empire… which included, for example, big chunks of what&#8217;s now Poland and Finland and other places.” She said that it is clear to her that Putin intends to restore this Russian Empire. Putin’s recent rhetoric has begun increasing these conversations about the safety of Russians within their own country.</span></p>
<p><span style="font-weight: 400;">   As the conflict in Ukraine continues to increase, ultimately it is the voices of bold individuals like Polic which will resound, “The Ukrainian people and the Ukrainian spirit are going to prevail. They’re already the victors in this war.”</span></p>
<p><span style="font-weight: 400;">  </span><span style="font-weight: 400;">Support Links:</span></p>
<p><span style="font-weight: 400;">Larkin created an NFT of a peace flag raised over the Motherland Monument in Kyiv, all proceeds will go to Ukraine in the form of cryptocurrency, </span><a href="https://opensea.io/assets/matic/0x2953399124f0cbb46d2cbacd8a89cf0599974963/72494236558156472721579357520817455851668296083155276642727801625076532610720"><span style="font-weight: 400;">click here</span></a><span style="font-weight: 400;"> if you would like to buy an NFT.</span></p>
<p><span style="font-weight: 400;">Dr. Kanevsky created a page with resources and support links that is constantly being updated. </span><a href="https://docs.google.com/document/u/0/d/1T7B4og2XIFHGWKwUbCU-2rnPOi7T8vGkrnYNTn8QzdE/edit"><span style="font-weight: 400;">Click here </span></a><span style="font-weight: 400;">to open it.</span></p>
<p><b>The House of Ukraine </b></p>
<p><span style="font-weight: 400;">House of Ukraine is a cultural museum in San Diego, Balboa Park, providing information to the public about the country of Ukraine. Their purpose is to promote and cultivate the art, history, customs, language, and traditions of Ukraine. They also sponsor educational presentations, demonstrations, and events devoted to Ukrainian culture.</span></p>
<p><a href="https://houseofukraine.org/donations/"><span style="font-weight: 400;">https://houseofukraine.org/donations/</span></a><span style="font-weight: 400;"> </span></p>
<p><b>UNICEF</b><span style="font-weight: 400;"> is on the ground before, during, and after emergencies, working to reach children and families with aid and long-term assistance. It is working with partners to reach vulnerable children and families with essential services – including health, education, protection, water and sanitation – as well as life-saving supplies.</span></p>
<p><a href="https://www.unicefusa.org/war-ukraine"><span style="font-weight: 400;">https://www.unicefusa.org/war-ukraine</span></a><span style="font-weight: 400;"> </span></p>
<p><span style="font-weight: 400;">The</span><b> Ukrainian Red Cross </b><span style="font-weight: 400;">helps those in need affected by armed conflict through blood collection, mobilization of volunteers and resources, and emergency activities.</span></p>
<p><a href="https://donate.redcrossredcrescent.org/ua/donate/~my-donation?_cv=1"><span style="font-weight: 400;">https://donate.redcrossredcrescent.org/ua/donate/~my-donation?_cv=1</span></a><span style="font-weight: 400;"> </span></p>
<p><b>Voices of Children,</b><span style="font-weight: 400;"> founded in 2015, </span><span style="font-weight: 400;">gives psychological and psychosocial support to children who suffered as a result of war operations. They are currently helping children across the country and assisting in the evacuation process.</span></p>
<p><a href="https://voices.org.ua/en/"><span style="font-weight: 400;">https://voices.org.ua/en/</span></a><span style="font-weight: 400;"> </span></p>
<p><b>Vostok-SOS</b><span style="font-weight: 400;"> is a non-governmental organization that assists in finding housing for displaced individuals, evacuation from areas of direct conflict, and distributing humanitarian and physiological aid to those impacted by the war.</span></p>
<p><a href="https://vostok-sos.org/en/ukraine-under-fire-support-vostok-sos-aid-operation/"><span style="font-weight: 400;">https://vostok-sos.org/en/ukraine-under-fire-support-vostok-sos-aid-operation/</span></a><span style="font-weight: 400;"> </span></p>
<p>&nbsp;</p>
</span><div class="clear"></div></div><ul class="snotags"><li class="blockstag"><a href="https://www.mesapress.com/tag/mesacollege/" rel="tag">#mesacollege</a></li><li class="blockstag"><a href="https://www.mesapress.com/tag/mesa-community/" rel="tag">Mesa community</a></li><li class="blockstag"><a href="https://www.mesapress.com/tag/mesa-press/" rel="tag">Mesa Press</a></li><li class="blockstag"><a href="https://www.mesapress.com/tag/san-diego-mesa-college/" rel="tag">San Diego Mesa College</a></li><li class="blockstag"><a href="https://www.mesapress.com/tag/ukraine/" rel="tag">Ukraine</a></li></ul></div>    	<div class="clear"></div>
		<div class="sno-comment-bar">
			Leave a Comment		</div>
		<div class="aboutwriter"><div class='aboutwritertitle'>About the Contributors</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='http://www.mesapress.com/wp-content/uploads/2021/09/D43568BD-59C3-4665-9764-57F7A3FDD95E-475x317.jpg' alt='Photo of Jennifer Aguilar'/></div><a href="http://www.mesapress.com/staff_profile/jennifer-aguilar/"><div class='sc_title'>Jennifer Aguilar, Editor-in-Chief</div></a><div class='sc_bio'><p>Jennifer Aguilar is the Editor-in-Chief at the Mesa Press. This is her second-year attending San Diego Mesa College, with a major in journalism. She will...</p><div class='clear'></div></div></div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='http://www.mesapress.com/wp-content/uploads/2022/02/25B78FAC-65EC-4764-97BB-344662C4328E-e1644514013637-475x351.jpg' alt='Photo of Teal Davis'/></div><a href="http://www.mesapress.com/staff_profile/teal-davis/"><div class='sc_title'>Teal Davis, Staff Writer</div></a><div class='sc_bio'><p>Teal Davis is a Staff Writer for the Mesa Press and a second-year student with San Diego Mesa College. She is currently majoring in Journalism. In her...</p><div class='clear'></div></div></div><div class="clear"></div></div></div><div id="sidebar" class="sidebar-template"><!-- Size: 11 -->
<div class='snoadnetwork'>
	<div class='sidebar-ad'>
		<script type="text/javascript">
			jQuery(document).ready(function( $ ) {
				retreive_ad();
				$('.sidebar-ad').on('click', '.sno-ad', function() {
					let ad_id = $(this).data('ad-id');
					url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
					jQuery.post(url, '', function(response) {
						console.log(response);
			        });
				});
				$('.sidebar-ad').on('click', '.sno-fill-ad', function() {
					url = 'https://snoads.com/site/273';
					window.open(url, '_blank');
				});
		        function retreive_ad() {
		        	var url = 'https://snoads.com/api/v1/adspot/383/serve'
		        	var fill_ad = "";
					jQuery.get(url, '', function(response) {
						if (response) {
							$('.sidebar-ad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" alt="Advertisement" /></a>');
						} else if (fill_ad) {
							$('.sidebar-ad').html('<img class="sno-fill-ad" src="' + fill_ad + '" alt="Advertisement" />');
						} else {
							let rand_num = Math.floor((Math.random() * 3) + 1);
							$('.sidebar-ad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/300x250_' + rand_num + '.jpg" alt="Advertisement" />');
						}
			        });
		        }
			});
		</script>
	</div>
</div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Recent Comments</div></div><div class="widgetbody"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Raa Rey</span> on <a href="https://www.mesapress.com/opinion/2021/11/13/too-sensitive-or-too-ignorant-the-rise-of-political-correctness-in-the-us/#comment-28823">Too sensitive or too ignorant? The rise of political correctness in the US</a></li><li class="recentcomments"><span class="comment-author-link">joker1230</span> on <a href="https://www.mesapress.com/a-e/2019/10/02/joker-movie/#comment-28822">&#8216;Joker&#8217; lets loose in the R-rated realm</a></li><li class="recentcomments"><span class="comment-author-link">chas holman</span> on <a href="https://www.mesapress.com/opinion/2014/05/08/does-a-transparent-administration-lie-to-the-public/#comment-28821">Does a transparent administration lie to the public?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://naturalwaystotreatanxiety.com/yoga-is-for-anyone-at-any-time/' rel='external nofollow ugc' class='url'>Yoga is for anyone at any time</a></span> on <a href="https://www.mesapress.com/uncategorized/2014/04/10/yoga-is-for-any-one-at-any-time/#comment-28639">Yoga is for anyone at any time</a></li><li class="recentcomments"><span class="comment-author-link">Timothy Phelps</span> on <a href="https://www.mesapress.com/opinion/2014/04/10/preaching-the-gospel-of-hate/#comment-28628">Preaching the gospel of hate</a></li></ul></div></div></section></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2022/03/25/remembering-zora-neale-hurston/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2022/03/zora-neale-hurston-picture-246x475.jpg' id='grow-stb17066'  style='width:70px;min-width:70px;' class='catboxphoto' alt='People tried to take Hurston down, but she kept going.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb17066').mouseenter(function() {
   											jQuery('#grow-stb17066').removeClass('shrink');
   											jQuery('#grow-stb17066').removeClass('grow');
   											jQuery('#grow-stb17066').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb17066').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2022/03/25/remembering-zora-neale-hurston/">Remembering Zora Neale Hurston</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2022/03/24/climbing-cost-of-living-in-san-diego-poses-challenges-for-mesa-students/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2022/03/IMG_7530-2-475x356.jpg' id='grow-stb17039'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='One gas station displays prices as the the cost of gas climbs across the San Diego County.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb17039').mouseenter(function() {
   											jQuery('#grow-stb17039').removeClass('shrink');
   											jQuery('#grow-stb17039').removeClass('grow');
   											jQuery('#grow-stb17039').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb17039').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2022/03/24/climbing-cost-of-living-in-san-diego-poses-challenges-for-mesa-students/">Climbing cost of living in San Diego poses challenges for Mesa students</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2022/02/28/mesa-welcomes-the-new-quad/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2022/02/Quad-475x356.jpeg' id='grow-stb16943'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Overhead view of the Quad  taken from the Math and Science Building'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16943').mouseenter(function() {
   											jQuery('#grow-stb16943').removeClass('shrink');
   											jQuery('#grow-stb16943').removeClass('grow');
   											jQuery('#grow-stb16943').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16943').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2022/02/28/mesa-welcomes-the-new-quad/">Mesa Welcomes the New Quad</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2022/02/22/grading-policy-changes-allow-students-to-chose-how-their-courses-are-graded/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2022/02/15993602825_dbb4d0a66b_c-475x344.jpg' id='grow-stb16909'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Mesa College students can now opt to have certain classes graded as pass/fail instead of a traditional letter grade.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16909').mouseenter(function() {
   											jQuery('#grow-stb16909').removeClass('shrink');
   											jQuery('#grow-stb16909').removeClass('grow');
   											jQuery('#grow-stb16909').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16909').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2022/02/22/grading-policy-changes-allow-students-to-chose-how-their-courses-are-graded/">New policy allows students choice in how courses are graded</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2022/02/13/new-california-legislation-repeals-statewide-universal-mask-mandate-beginning-february-15/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2022/02/20220211-AMX-LIFE-STATES-ARE-DROPPING-MASK-MANDATES-1-PHI-475x317.jpg' id='grow-stb16878'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='A person wearing a mask sits among signs that promote social distancing with seating at City Hall in January.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16878').mouseenter(function() {
   											jQuery('#grow-stb16878').removeClass('shrink');
   											jQuery('#grow-stb16878').removeClass('grow');
   											jQuery('#grow-stb16878').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16878').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2022/02/13/new-california-legislation-repeals-statewide-universal-mask-mandate-beginning-february-15/">New California Legislation Repeals Statewide, Universal Mask Mandate Beginning February 15</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2021/12/13/legendary-mexican-singer-vicente-fernandez-dies-at-the-age-of-81/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2021/12/ENTER-MUS-FERNANDEZ-DEATH-SON-2-LA-475x313.jpg' id='grow-stb16802'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Legendary Vicente Fernandez dies at the age of 81. '/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16802').mouseenter(function() {
   											jQuery('#grow-stb16802').removeClass('shrink');
   											jQuery('#grow-stb16802').removeClass('grow');
   											jQuery('#grow-stb16802').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16802').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2021/12/13/legendary-mexican-singer-vicente-fernandez-dies-at-the-age-of-81/">Legendary Mexican Singer Vicente Fernández dies at the age of 81</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2021/12/09/what-spring-semester-at-mesa-college-will-look-like/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2021/12/page-1-photo-475x317.jpg' id='grow-stb16792'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Mesa College with be fully opened for the spring 2022 semester, with a few changes.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16792').mouseenter(function() {
   											jQuery('#grow-stb16792').removeClass('shrink');
   											jQuery('#grow-stb16792').removeClass('grow');
   											jQuery('#grow-stb16792').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16792').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2021/12/09/what-spring-semester-at-mesa-college-will-look-like/">What spring semester at Mesa college will look like</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2021/12/08/grand-opening-of-the-mesa-college-dreamer-resource-center/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2021/12/Dreamers-475x317.jpg' id='grow-stb16780'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Mesa College students cut the ribbon marking the grand opening of the Dreamer Resource Center. '/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16780').mouseenter(function() {
   											jQuery('#grow-stb16780').removeClass('shrink');
   											jQuery('#grow-stb16780').removeClass('grow');
   											jQuery('#grow-stb16780').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16780').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2021/12/08/grand-opening-of-the-mesa-college-dreamer-resource-center/">Grand opening of the Mesa College Dreamer Resource Center</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2021/11/02/a-look-into-san-diego-mesa-colleges-new-chancellor/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2021/03/Carlos.Cortez-2-458x475.jpg' id='grow-stb16685'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Dr. Carlos O. Turner-Cortez has a funny suspicion hes going to enjoy being chancellor for the next decade.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16685').mouseenter(function() {
   											jQuery('#grow-stb16685').removeClass('shrink');
   											jQuery('#grow-stb16685').removeClass('grow');
   											jQuery('#grow-stb16685').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16685').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2021/11/02/a-look-into-san-diego-mesa-colleges-new-chancellor/">A look into SDCCD&#8217;s new chancellor</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.mesapress.com/news/2021/11/02/san-diegans-fight-back-against-upcoming-mask-and-vaccine-mandate/#photo'><img src='https://www.mesapress.com/wp-content/uploads/2021/11/Let-them-breathe-rally-475x397.jpg' id='grow-stb16680'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='San Diegans rally together to protest the new mask and vaccine mandate effective Dec. 1.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb16680').mouseenter(function() {
   											jQuery('#grow-stb16680').removeClass('shrink');
   											jQuery('#grow-stb16680').removeClass('grow');
   											jQuery('#grow-stb16680').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb16680').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.mesapress.com/news/2021/11/02/san-diegans-fight-back-against-upcoming-mask-and-vaccine-mandate/">San Diegans fight back against upcoming mask and vaccine mandate</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 300,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footeradboardwrap">
	<div class="footeradboard">
		<div class="footerad snoads_footerad" data-ad_spot_id="925" data-ad_fill="" data-sno_ads_id="273"></div>
	</div>
</div><div class="footerwrap footer_single"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="http://www.mesapress.com">The Mesa Press</a></p></div><div class="footerright footer-icon"><style>.topnavbarleft { padding: 0px; width:auto; }</style>    	<a target="_blank" href="https://www.mesapress.com/feed/rss/">
        	<div class="sno-icon social-border sno-rss">
	        	<i class="fa fa-rss"></i>
	        	<span class="icon-hidden-text">RSS Feed</span>
	        </div>
		</a>
        
        								   	    										
    
        				
   	    
    
    
    		<a target="_blank" href="https://www.snapchat.com/add/mesa.press">
    		<div class="sno-icon social-border sno-snapchat">
        		<i class="fa fa-snapchat-ghost"></i>
        		<span class="icon-hidden-text">Snapchat</span>
        	</div>
    	</a>
        				
        				    					
    		<a target="_blank" href="https://soundcloud.com/mesa-press-audio-archive">
    		<div class="sno-icon social-border sno-soundcloud">
        		<i class="fa fa-soundcloud"></i>
        		<span class="icon-hidden-text">SoundCloud</span>
        	</div>
    	</a>
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/mesa.press">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="http://www.twitter.com/themesapress">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/themesapress">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   </div></div><div class="footertagline"><p>The independent student news site of San Diego Mesa College.</p></div><div class="footersearch">	<form method="get" id="searchform4383" action="https://www.mesapress.com/">
			<div class="search-button-container" id="searchthis4383">
			<button type="submit" disabled="disabled" id="sno-search-navbar-4383" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s4383" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s4383" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit4383" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footermenu"><div class="footer-menu"><ul>
<li class="page_item page-item-25"><a href="https://www.mesapress.com/about/">About The Mesa Press</a></li>
<li class="page_item page-item-1594"><a href="https://www.mesapress.com/advertise-with-the-mesa-press/">Advertise with The Mesa Press</a></li>
<li class="page_item page-item-2510"><a href="https://www.mesapress.com/classifieds/">Classifieds</a></li>
<li class="page_item page-item-24"><a href="https://www.mesapress.com/staff/">Staff</a></li>
</ul></div>
</div><div class="clear"></div><div class="footercredit"><div class="sno-footer-credit-inner">&copy; 2022  &bull; <a target='_blank' href='https://snoads.com/site/273'>Advertise</a> &bull;  <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://www.mesapress.com/wp-login.php">Log in</a></div></div><div class="clear"></div></div></div>		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-22842225-11', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
	<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.mesapress.com/wp-admin/admin-ajax.php";
</script>
	<div class="sno-side-icons icon-standard icon-hover-standard">
					<div class="comment-side-icon sno-side-icon sno-side-icon-6">
				<div class="sno-side-icon-ring">
										<i class="fa fa-comments-o"></i>
				</div>
			</div>
							<div class="like-side-icon sno-side-icon sno-side-icon-6" data-liked="0" data-remember="1" data-post="17070" >
				<div class="sno-color-inverter" data-ce99983c01c45d2e2447b531a1c33f9f="8831f5395fec7db00aa5dc4448a0f425"></div>
				<div class="sno-side-icon-ring">
					<div class="sno-side-icon-bubble like-count-bubble like-count-hide">
						0					</div>
					<i class="fas fa-thumbs-up"></i>
				</div>
			</div>
							<a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mesapress.com%2Funcategorized%2F2022%2F03%2F28%2Frussian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community%2F" title="Share on Facebook" target="_blank">
				<div class="facebook-side-icon sno-side-icon sharing-mobile-show sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-facebook-f"></i>
						<span class="icon-hidden-text">Share on Facebook</span>
					</div>
				</div>
			</a>
							<a class="modal-share" href="https://twitter.com/intent/tweet?text=Russian invasion of Ukraine hits close to home for the Mesa community&amp;url=https%3A%2F%2Fwww.mesapress.com%2F%3Fp%3D17070&amp;via=themesapress" title="Tweet This Story" target="_blank">
				<div class="twitter-side-icon sno-side-icon sharing-mobile-show sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-twitter"></i>
						<span class="icon-hidden-text">Share on Twitter</span>
					</div>
				</div>
			</a>
											<a href="#" onclick="return false;" class="modal-share share-email sharing-mobile-show" title="Email this Story">
				<div class="email-side-icon sno-side-icon sno-side-icon-6" data-story-id="17070">
					<div class="sno-side-icon-ring">
						<i class="fa fa-envelope"></i>
						<span class="icon-hidden-text">Share via Email</span>
					</div>
				</div>
			</a>
													<a rel="nofollow" href="//www.mesapress.com/uncategorized/2022/03/28/russian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community/?print=true" title="Print this Story">
				<div class="print-side-icon sno-side-icon sharing-mobile-show sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-print"></i>
						<span class="icon-hidden-text">Print</span>
					</div>
				</div>
			</a>
			</div>
	<div id="sno_hoversearch"><div class="sno-search-close"style="float:right;"><i class="fas fa-times"></i></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://www.mesapress.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button"><i class="fa fa-search"></i><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up"><i class="fa fa-arrow-up"></i><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://www.mesapress.com/wp-content/uploads/2020/02/MesaPressInsta.jpg" alt="The independent student news site of San Diego Mesa College." /></a></div><div class="hover_title"><div class="hover_titletext">Russian invasion of Ukraine hits close to home for the Mesa community</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://www.mesapress.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-201"><a href="https://www.mesapress.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="https://www.mesapress.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15052"><a href="https://www.mesapress.com/category/a-e/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="https://www.mesapress.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11291"><a href="https://www.mesapress.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16342"><a href="https://www.mesapress.com/advertise-with-the-mesa-press/">Advertise with The Mesa Press</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16343"><a href="https://www.mesapress.com/?page_id=9968">Classifieds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16344"><a href="https://www.mesapress.com/about/">About The Mesa Press</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16345"><a href="https://www.mesapress.com/staff/">Staff</a></li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
				// disabling this feature when using new scrollToFix elements in header
				if( jQuery('.sno-header-row-stick').length ) return;
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - 100;
				if( jQuery('.footer').length ) WindowHeight -= jQuery('.footer').height();
				
				jQuery(window).scroll(function(event) {

					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
										
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script><div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div>		<div id="sno-comments-side">
			<div class="sno-comments-wrap">
				<div id="sno-comments-header">
					<div class='fas fa-times comment-close-icon'></div>
					<div class="sno-comments-title"><h3>Comments (0)</h3></div>
				</div>
									<div class="sno-comments-policy">
						Here at The Mesa Press, we want to foster a community for civil discussions.
We welcome your insight and perspective. Comments posted must be appropriate for all ages. Any profanity or cursing is prohibited. That includes any attempts to curse with special characters (!@#) or spacing.
Discuss and criticize ideas. We don’t allow comments that intend to intimidate, demean or harass other readers in any way.					</div>
									<div class="clear"></div>
									<input class="comments-share-thoughts" type="text" placeholder="Share your thoughts..." name="comments-thoughts"/>
								<div class="comments-toggle">
					<span class="comments-all comments-toggle-active">All</span>
									<span class="comments-staff-picks">The Mesa Press Picks</span>
													<span class="comments-reader-picks">Reader Picks</span>
									<span class="comments-sort" data-sort="newest">Sort: <span class="active-sort">Newest</span></span>
				</div>
									<div id="comments" class="comments-area default-max-width show-avatars">
		<div id="respond" class="comment-respond">
		<p id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/uncategorized/2022/03/28/russian-invasion-of-ukraine-hits-close-to-home-for-the-mesa-community/#respond" style="display:none;">Cancel reply</a></small></p><form action="https://www.mesapress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><div class="sno_spam_control"><label for="spam_stopper">Spam Control Field.</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/><label for="sno-verification">Verification Field.</label><input type="text" name="sno-verification" class="sno-verification" id="sno-verification" value="ee6936aa733707d66f1537f20c5551318831f5395fec7db00aa5dc4448a0f425"/></div><input id="wp-remember" type="hidden" name="wp-remember" value="1" /><div class="sno-comment-id" data-55018e43733d0a327afcfffadb00c40d="8831f5395fec7db00aa5dc4448a0f425"></div><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='17070' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	</div>							</div>
		</div>
		<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.mesapress.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-includes/js/comment-reply.min.js?ver=5.9.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/Chart.js/3.5.0/chart.min.js?ver=1.0.0' id='chartsjs-main-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/chroma-js/2.1.0/chroma.min.js?ver=1.0.0' id='chroma-lib-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/d3/3.5.3/d3.min.js?ver=1.0.0' id='d3-lib-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/topojson/1.6.9/topojson.min.js?ver=1.0.0' id='topo-json-js'></script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-infographics//assets/datamaps/datamaps.all.min.js?ver=1.0.0' id='datamap-main-js'></script>
<script type='text/javascript' id='sno-infographics-widget-script-js-extra'>
/* <![CDATA[ */
var sno_infographics_ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-infographics/assets/script/sno-infographics-widget.js?ver=0.2.7' id='sno-infographics-widget-script-js'></script>
<script type='text/javascript' src='https://code.jquery.com/ui/1.12.1/jquery-ui.js?ver=5.9.2' id='ui-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-plugin-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/script/sno-pdf-flipbook-script.js?ver=1.0.5' id='sno-pdf-flipbook-plugin-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-turnjs-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/script/turn.js?ver=1.0.0' id='sno-pdf-flipbook-turnjs-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-mousewheel-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/script/jquery.mousewheel.min.js?ver=1.0.0' id='sno-pdf-flipbook-mousewheel-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-hash-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/script/hash.js?ver=1.0.0' id='sno-pdf-flipbook-hash-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-modernizr-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-pdf-flipbook/assets/script/modernizr.2.5.3.min.js?ver=1.0.0' id='sno-pdf-flipbook-modernizr-script-js'></script>
<script type='text/javascript' id='custom-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-polls/assets/script/sno-polls-widget.js?ver=0.0.6' id='custom-widget-script-js'></script>
<script type='text/javascript' id='custom-test-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-polls/assets/script/sno-polls-test-widget.js?ver=0.0.5' id='custom-test-widget-script-js'></script>
<script type='text/javascript' id='custom-quiz-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/sno-polls/assets/script/sno-polls-quiz-widget.js?ver=0.0.3' id='custom-quiz-widget-script-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.mesapress.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mesapress.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<div id='sno-pdf-flipbook-full'></div></div></body></html>